请选择 进入手机版 | 继续访问电脑版

顶牛论坛

扫一扫,访问微社区

QQ登录

只需一步,快速开始

查看: 393|回复: 0

通达信股王抓涨停主图指标公式

[复制链接]
  • TA的每日心情
    开心
    2017-9-24 23:17
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    69

    主题

    114

    帖子

    542

    积分

    高级会员

    Rank: 4

    积分
    542
    发表于 2018-10-24 09:35:30 | 显示全部楼层 |阅读模式
    ZGD:=HHV(H,90)*0.99;
    ZGD2:=CONST(ZGD);
    ZDD:=LLV(L,90);
    ZDD2:=CONST(ZDD);
    {DRAWBAND(ZGD2,RGB(50,50,50),ZDD2,DRAWNULL);}
    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
    VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
    红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
    青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
    短买:VAR19,REF(CLOSE,1),REF(CLOSE,2),COLOR33AACC,NODRAW;
    品红离场:VAR1A,REF(CLOSE,1),REF(CLOSE,2),COLORFF99FF,NODRAW;
    急速超跌: (CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
    上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
    月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
    日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
    STICKLINE(红色持股,CLOSE,REF(CLOSE,1),5,0),COLOR0000FF;
    STICKLINE(青色观望,CLOSE,REF(CLOSE,1),5,0),COLORFFFF00;
    STICKLINE(短买,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR33AACC;
    STICKLINE(品红离场,REF(CLOSE,1),REF(CLOSE,2),5,0),COLORFF99FF;
    STICKLINE(急速超跌,REF(CLOSE,1),C,5,0),COLORFFFFFF;
    STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
    STICKLINE(C<O,L,H,0,0),COLOR999900;
    STICKLINE(1,C,O,2.5,0),COLOR454500;
    STICKLINE(1,C,O,2,0),COLOR555500;
    STICKLINE(1,C,O,1.5,0),COLOR656500;
    STICKLINE(1,C,O,1,0),COLOR757500;
    STICKLINE(1,C,O,0.5,0),COLOR858500;
    STICKLINE(C>=O,C,O,2.5,0),COLOR000045;
    STICKLINE(C>=O,C,O,2,0),COLOR000085;
    STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
    STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
    STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
    DRAWTEXT(VAR19,REF(CLOSE,1),'←短买'),COLOR33FFCC;
    DRAWTEXT(VAR1A,REF(CLOSE,1)+0.1,'←离场'),COLORFF99FF;
    MA3:=MA(CLOSE,3);
    YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
    辰星线: (20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
    牵牛线:MA(CLOSE,26),COLORFF00FF;
    等待:=IF(MA3>辰星线,辰星线,MA3);
    IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR0000FF;
    IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;
    IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;
    IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;

    如下图所示:


    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则


    广告

    Archiver|手机版|小黑屋|联系我们| 顶牛网  

    GMT+8, 2019-10-21 17:38 , Processed in 0.224437 second(s), 34 queries .

    Powered by Discuz! X3.2

    © 2007-2016 Dingniu888.com

    快速回复 返回顶部 返回列表