请选择 进入手机版 | 继续访问电脑版

顶牛论坛

扫一扫,访问微社区

QQ登录

只需一步,快速开始

查看: 2454|回复: 2

通达信预测明日走势主图指标公式

  [复制链接]
  • TA的每日心情
    开心
    2017-9-24 23:17
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    69

    主题

    114

    帖子

    542

    积分

    高级会员

    Rank: 4

    积分
    542
    发表于 2016-11-11 19:07:51 | 显示全部楼层 |阅读模式
    本帖最后由 xiaoxiao 于 2016-11-11 19:12 编辑

    MA5:MA(CLOSE,5);
    MA10:MA(CLOSE,10);
    MA30:MA(CLOSE,30);
    MA60:MA(CLOSE,60);
    红轨道:=MA(MA(CLOSE,3),1),LINETHICK1,COLORYELLOW;
    绿轨道:=MA(MA(CLOSE,3),3);
    上升:IF(红轨道>=绿轨道,绿轨道,DRAWNULL),COLORRED,LINETHICK3;
    AA1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
    加仓:=IF(CROSS(AA1,REF(AA1+0.01,1)) AND LLV(AA1,2)=LLV(AA1,8) AND
    BETWEEN(AA1,20,60),1,0);
    波段底:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27)
    - LLV(LOW,27)))*(100),5,1)) -
    (2)*(SMA(SMA(((CLOSE -
    LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
    DRAWICON(加仓,L*0.97,7);
    DRAWICON(CROSS(波段底,3),L*0.97,1);
    A:=(3*C+L+O+H)/6;
    X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
    14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
    +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
    REF(A,20))/210;
    MTM:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    CB:=EMA(X,13);
    卖:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
    DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORWHITE;
    买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
    DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),COLORRED;
    RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
    注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
    DRAWTEXT(注意 AND
    卖!=1,HIGH*1.02,'减'),COLORLIBLUE;
    加仓A:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
    DRAWTEXT(FILTER((CROSS(加仓A,0) OR CROSS(CLOSE,CB)) AND
    买!=1,3),LOW-0.03,'加'),COLOR0080FF;
    MA18:=MA(C,18);
    跟:=IF(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18),1,0);
    DRAWTEXT(MA18>=REF(MA18,3) AND
    CROSS(CLOSE,MA18),LOW*0.96,'跟'),COLOR7F52AF;
    买价:=((C-REF(MA5,1))/5+MA5)*1.004;
    买条件:=CROSS(C,买价) AND 买价>REF(买价,1);
    白K线买进:IF(买条件,L,H),COLORWHITE,POINTDOT;
    STICKLINE(买条件,H,L,0,1),COLORWHITE,LINETHICK2;
    STICKLINE(买条件,O,C,4,1),COLORWHITE,LINETHICK2;
    加码价:=((C-REF(MA10,1))/20+MA10)*1.004;
    加码条件:=CROSS(C,加码价) AND
    加码价>REF(加码价,1);
    黄K线加码:IF(加码条件,L,H),COLORYELLOW,POINTDOT;
    STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;
    STICKLINE(加码条件,O,C,4,1),COLORYELLOW,LINETHICK2;
    P1:=5;
    P2:=10;
    P3:=20;
    P4:=30;
    P5:=60;
    P6:=120;
    P7:=240;
    P8:=340;
    N:=4;
    WX:=MA(CLOSE,0);
    M1:=MA(CLOSE,P1);
    M2:=(MA(CLOSE,P2) * IF((N < 2),WX,1));
    M3:=(MA(CLOSE,P3) * IF((N < 3),WX,1));
    M4:=(MA(CLOSE,P4) * IF((N < 4),WX,1));
    M5:=(MA(CLOSE,P5) * IF((N < 5),WX,1));
    M6:=(MA(CLOSE,P6) * IF((N < 6),WX,1));
    M7:=(MA(CLOSE,P7) * IF((N < 7),WX,1));
    M8:=(MA(CLOSE,P8) * IF((N < 8),WX,1));
    C1:=REF(CLOSE,1);
    C2:=HHV(C1,2);
    C3:=LLV(C1,1);
    ET:=HHV(C1,2);
    ET1:=REF(ET,1);
    XB:=LLV(C1,1);
    XB1:=REF(XB,1);
    M:=BARSLAST(((CLOSE < XB) AND (C1 >= XB1)));
    M11:=REF(M,1);
    N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1)));
    N1:=REF(N9,1);
    M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1);
    N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1);
    ET2:=HHV(ET,M21);
    XB2:=LLV(XB,N2);
    H1:=IF(((M - N9) > 0),CLOSE,ET2);
    H2:=IF((A = 1),CLOSE,C2);
    H3:=IF(((M - N9) < 0),CLOSE,XB2);
    H4:=IF((A = 1),CLOSE,XB2);
    H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3);
    H6:=REF(H5,1);
    H7:=REF(H5,2);
    H8:=(H5 > H6);
    H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2)));
    H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
    W:=((H8 OR H9) OR H10);
    T9:=((H5 < H6) AND (H5 < REF(H5,2)));
    T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2)));
    T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1)));
    T12:=((H5 = REF(H5,1)) AND (H3 = H4));
    T13:=((H2 = REF(H2,1)) AND (H2 = H5));
    TW:=((((T9 OR T10) OR T11) OR T12) OR T13);
    PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);
    PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
    BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
    STICKLINE((ISLASTBAR AND W),(H5 * 1.025),(H5 * 0.99),0.5,0),COLORFF8800;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,8,0),COLOR102088;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,7,0),COLOR102099;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,6,0),COLOR1020AA;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,5,0),COLOR1020BB;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,4,0),COLOR1020CC;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,3,0),COLOR1020DD;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,2,0),COLOR1020EE;
    STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,1,0),COLOR1020FF;
    DRAWTEXT((ISLASTBAR AND (BBP >= 96.5)),(H5 * 1.022),'明见-短高-龙头-除外'),COLORRED;
    DRAWTEXT((ISLASTBAR AND (BBP < 1)),((H5 + H4) / 1.96),'明见-短低-跌停-除外'),COLORGREEN;
    DRAWTEXT(((ISLASTBAR AND W) AND (BBP < 96.5)),(H5 * 1.022),'明日看涨'),COLORYELLOW;
    DRAWTEXT(((ISLASTBAR AND TW) AND (BBP > 1)),((H5 + H4) / 2),'明日看跌'),COLORGREEN;

    回复

    使用道具 举报

  • TA的每日心情
    开心
    2017-9-24 23:17
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    69

    主题

    114

    帖子

    542

    积分

    高级会员

    Rank: 4

    积分
    542
     楼主| 发表于 2016-11-11 19:10:41 | 显示全部楼层

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即注册

    x
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    无聊
    2017-1-11 15:38
  • 签到天数: 1 天

    [LV.1]初来乍到

    1

    主题

    2

    帖子

    30

    积分

    新手上路

    Rank: 1

    积分
    30
    发表于 2016-11-22 19:49:27 | 显示全部楼层
    谢谢分享:handshake
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则


    广告

    Archiver|手机版|小黑屋|联系我们| 顶牛网  

    GMT+8, 2019-9-16 13:12 , Processed in 0.292683 second(s), 33 queries .

    Powered by Discuz! X3.2

    © 2007-2016 Dingniu888.com

    快速回复 返回顶部 返回列表